Degraded Login Performance
Incident Report for Admirals
Resolved
This incident has been resolved.
Posted Dec 14, 2023 - 17:46 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 14, 2023 - 16:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 14, 2023 - 15:32 UTC
Investigating
We are currently investigating this issue.
Posted Dec 14, 2023 - 15:30 UTC
This incident affected: WEB (Main web), MT5 (MT5 Live, MT5 Demo), MT4 (MT4 Live, MT4 Live 2, MT4 Live 3, MT4 Demo), Mobile App (Mobile App Live, Mobile App Demo), and Web Trader.