Login performance issue
Incident Report for Admirals
Resolved
This incident has been resolved.
Posted Nov 03, 2023 - 20:39 UTC
Update
We are continuing to investigate this issue.
Posted Nov 03, 2023 - 18:56 UTC
Investigating
Dear customers, We're currently addressing a minor performance issue
We are investigating the root cause of the issue. The issue is not affect Trading services. If you need help, please contact customer service with any questions.
Posted Nov 03, 2023 - 14:13 UTC
This incident affected: WEB (Main web), MT5 (MT5 Live, MT5 Demo), MT4 (MT4 Live, MT4 Live 2, MT4 Live 3, MT4 Demo), Mobile App (Mobile App Live, Mobile App Demo), and Dashboard, Web Trader.